Service disruption on US2 ZAF application
Incident Report for Tymeshift
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 12:41 CDT
Investigating
We are currently investigating this issue.
Posted Oct 09, 2020 - 12:05 CDT
This incident affected: US2 (Zendesk App).