Service slow
Incident Report for Tymeshift
Resolved
This incident has been resolved.

We apologize for the inconvenient this caused and we really appreciate your continued trust.
Posted 13 days ago. Nov 29, 2018 - 13:09 CST
Update
We are continuing to work on a fix for this issue.
Posted 13 days ago. Nov 29, 2018 - 12:54 CST
Identified
The issue has been identified and a fix is being implemented.
We will update you as soon as possible.

Thanks for your patience.
Posted 13 days ago. Nov 29, 2018 - 11:35 CST
This incident affected: US1 (Application).