Rules function issue
Incident Report for Tymeshift
Postmortem

Summary

Between October 22nd at 21:08 CST and October 23rd at 6:26 CST customers experienced an issue with Tymeshift related to the the Rules functionality not running automatically. This issue impacted customers with rules configured. Since Rules were unable to run, this caused issues with agents whom were idle and did end their day remaining clocked in to Tymeshift and their day not being automatically ended or past timesheets removed.

Cause

This issue was caused due to a partial infrastructure related to the service responsible for running the automated rules.

We have repaired the issue and are doing two key things to prevent this in the future:

1) Improving our infrastructure configuration to automatically recover in the event of a failure

2) Implementing additional redundancy mechanisms

We apologize for the inconvenience this may have caused.

Posted 8 months ago. Oct 30, 2018 - 11:03 CDT

Resolved
On October 22nd to the 23rd Customers experienced an issue with Tymeshift related to the the Rules functionality not running automatically. This issue impacted customers with rules configured. Since Rules were unable to run, this caused issues with agents whom were idle and did end their day remaining clocked in to Tymeshift and their day not being automatically ended or past timesheets removed. This issue was caused due to a partial infrastructure related to the service responsible for running the automated rules.
Posted 8 months ago. Oct 23, 2018 - 00:00 CDT